Author Topic: uninstall and install of nrComm.NET  (Read 458 times)

umez

  • Newbie
  • *
  • Posts: 6
    • View Profile
uninstall and install of nrComm.NET
« on: February 27, 2015, 01:09:28 pm »
Hello.
I was helped about installing nrComm.NET last of July.
   Subject: Please tell me how to distribute, nrComm NET

Thank you all!

I have changed the development PC.
Unfortunately, the same problem occurs with the last year with a new PC.  :'(
(Of course, I did activate the license by moving in with administrator privileges the Visual Studio)

Please tell me the following two points.

  [Q1] I want to remove completely the nrComm.NET from my PC.
       (I want to redo the Activate.)
       What operation was or should be.

  [Q2] correct installation procedure of nrComm.NET.


<Background of problem>
My PC was over broken.
I bought a new PC.
To a new PC, I have installed the Visual Studio and nrComm.NET.

    * OS is Windows7 Pro + SP1 (x86)
    * User is Domain Administrator group.
    * UAC is pointing to a second from the top.
    * NrComm.NET I use in VS2013.
      For another job, have also been installed VS2008.
      (The VS2008, for development Windows Embedded Compact)

<Installation & Test>
  1) Installing VS2008 & VS2013 Update4
  2) From your site, I have downloaded the following files
         nrCommnet.msi
  3) Installing nrCommnet.msi
  4) To start with administrator privileges VS2013.

(The IDE of VS2008 nrComm.NET is automatically registered.
But the IDE of VS2013 are not registered. For manual registration,
use the temporary project in the following)

  5) Create a new project.
  6) Click the [Tool]-[Choose Toolbox Items] from the menu of the IDE.
  7) Select ".NET Framwork Components" tab in the Choose Toolbox Items Dialog.
  8) Click the [Browse] button.
  9) "C:\Program Files\nrComm NET\bin\nrComm.Core.dll" Choose.
 10) nrComm.NET-related components are displayed in the Choose Toolbox Items Dialog.
 11) In form design window, and Drag & Drop the "nrComm" Component.
 12) NAG screen for activation is displayed. to activate using the license file.
 13) I close the project.
 14) I open a project that use the nrComm.NET. (This is one that was developed in the last year in July)
 15) And instructed to "Clean" and "Rebuild" in the IDE.
 16) Copy the resulting "exe" and "nrComm.Core.dll" to another PC.
 17) Operation test on another PC. NAG screen from being displayed.

Then, I tried many things.
I went that I had taught before. I have deleted the license file from the following folder.
In addition I was also uninstall and reinstall of nrComm.NET.

I have to change the settings for the UAC, tried also re-installation of nrComm.NET.

But NAG screen for activation, had gone out again.
And, NAG screen in another PC is displayed.  :'(

umez

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: uninstall and install of nrComm.NET
« Reply #1 on: March 01, 2015, 02:51:56 pm »
Hello.

This problem has not been solved yet.  :'(
But we report became a little better.  :)

I was working in the user's "Domain Admins" Group until now.
I quit this.
I was logged on with another user.
The user is not a domain user. It is a local user account.
Its user is "Administrators" and "Users" group.

I went to uninstall and install this user.
Then window for the Activation is now being displayed.
I got to be able to try the work of Activation again.
Using the license file that I have received previous Activation be successful.

I have compiled.
I have copied the exe and DLL to other PC.
And I was executed.
But still NAG screen is displayed.

I think that it try out a little more variety.
Please tell me if you have any hints.

<Procedure>
 1. Log out the user's "Domain Admins".
 2. Log on locally user account.
 3. Select [Uninstall Program] of the Control Panel. Uninstall the nrComm NET.
 4. I will check the following two folders.
        C:\Windows\assembly\GAC_MSIL\nrComm.Core\3.7.0.10__f936bded66c9b7be\
        C:\Users\All Users\DeepSoftware\
    The first one does not exist.
    The second thing exists. Remove "DeepSoftware" folder.
 5. I restart the PC.
 6. Launch VS2013 with administrator privileges
 7. Create a new project
 8. In form design screen, and Drag & Drop the "nrComm" Component.
      --> Window for the Activation is displayed.

umez

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: uninstall and install of nrComm.NET
« Reply #2 on: March 04, 2015, 10:33:57 am »
Hello.

This problem was solved. :)
I leave describe summarized below.

<Point>
* Domain account and the user account the difference was no.
* I was using the wrong license file.

Sorry.

<Description>
* When the activation window does not appear, it appears if log on local account.
  Then I found the following.

  -- Activation window no longer appears in the local account.
     When apparently has repeated activation process, it seems become bad.

  -- It might be because of the number of times of the activation process.
     Alternatively, if something fails with the activation process, it might become so.

  -- This matter, if a certain process, again activation window is found to be to be displayed.

* Run the exe in-other PC. Then NAG screen from being displayed.
  This was also my mistake.
  I had the wrong license file that should be used.

  I received last year two license files.

  The first I got after the license purchase.
  The second I got after I contacted the problem of activation.

  I was going to have to this time, the processing in the second license file.
  However, I was unawares wrong file copy process.
  I was using the first license file.

  I noticed it. I try again activation using a second license file.
  Problem was solved.
  Sorry.

* Just in case, I tried to re-confirm the matter to run the VS as administrator.
  I tried the activation in VS without using the "Run as administrator".
  I failed to processing.
  An error message is not displayed, it is different from the time that
  placement of license file was able to correctly activation.
  Activation process requires "Run as administrator" of VS.