Author Topic: Chars: $@^_`| has been sent wrong  (Read 798 times)

Alex Teza

  • Newbie
  • *
  • Posts: 5
    • View Profile
Chars: $@^_`| has been sent wrong
« on: January 04, 2012, 04:11:03 pm »
Hi Roman,

I'm sent a SMS in PDU mode with coding pc7bit.
The message contain this chars: $@ˆ_`| between others.
This chars has been sent wrong.
The target device the message receive: ¤¡ ?

help me please.

Roman Novgorodov

  • Engineer
  • Administrator
  • Hero Member
  • *****
  • Posts: 994
  • we will win
    • View Profile
    • Forums.nrCommLib.Com
Re: Chars: $@^_`| has been sent wrong
« Reply #1 on: January 05, 2012, 06:04:26 pm »
Hello

Thank you for your information.

We have tested today again. All seems ok.

Please download latest version of GSM demo from here:
http://deepsoftware.com/nrcomm/gsmdemo_32.zip

This version has extended options of SMS sending TAB.
You can double click on sms memo, and app generates chars from 21h to 7Eh
Select 7bit coding, enter destination phone address and click Send.

Our Nokia phone receives all char correctly except 60h code. Windows shows `but gsm device shows inverted question mark.
It accords to GSM specification.
See this table:
http://www.dreamfabric.com/sms/default_alphabet.html

Roman Novgorodov
DeepSoftware llc
DeepSoftware llc - The professional components for Delphi/CBuilder/.NET. The high quality custom software development.
Forums.nrCommLib.Com - DeepSoftware Tech Support Forum.

Alex Teza

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Chars: $@^_`| has been sent wrong
« Reply #2 on: January 06, 2012, 01:05:49 pm »
Hi Roman,

I tryed send again with your new GSM demo, but the problem occurred again.
If possible send me a SMS with this chars from this GSM demo.
My phone number is +554199952110.

Thanks.

PS: I'm using the Delphi 2010.

Roman Novgorodov

  • Engineer
  • Administrator
  • Hero Member
  • *****
  • Posts: 994
  • we will win
    • View Profile
    • Forums.nrCommLib.Com
Re: Chars: $@^_`| has been sent wrong
« Reply #3 on: January 06, 2012, 02:13:01 pm »
Hello

Please post here LOG file of your testing with GSMDemo.

Roman Novgorodov
DeepSoftware LLC
DeepSoftware llc - The professional components for Delphi/CBuilder/.NET. The high quality custom software development.
Forums.nrCommLib.Com - DeepSoftware Tech Support Forum.

Alex Teza

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Chars: $@^_`| has been sent wrong
« Reply #4 on: January 09, 2012, 11:23:29 am »
Hi Roman,

I discovered that in Brazil exists a problem between the GSM companys.
They not operate with 8bit and some chars is interpreted wrong.
Example: From TIM to TIM the chars is sent totaly correct, but from TIM to CLARO or VIVO is sent wrong and the inverse is sent wrong also.
Then the component is sent the message correctly, but the GSM Company have a "Comunication problem";D.

Thanks for your help.

Roman Novgorodov

  • Engineer
  • Administrator
  • Hero Member
  • *****
  • Posts: 994
  • we will win
    • View Profile
    • Forums.nrCommLib.Com
Re: Chars: $@^_`| has been sent wrong
« Reply #5 on: January 09, 2012, 05:05:19 pm »
Hello

Thank you for detail information.

Roman Novgorodov
DeepSoftware LLC
DeepSoftware llc - The professional components for Delphi/CBuilder/.NET. The high quality custom software development.
Forums.nrCommLib.Com - DeepSoftware Tech Support Forum.